If you are finding it difficult to post new posts, any of these reasons might help.

You just registered

If you just registered, your user account must be manually approved. You have to wait for an approval e-mail from Sword Forum International which will contain a link to verify you're really you.

  • If you supplied a fake e-mail address, you will not receive this.
  • You may need to check your SPAM or Junk folder in case your e-mail system routed it there.
  • Registration requires a response to that e-mail.
  • If your user name was a nickname, it may have gotten deleted. Try re-registering using the SAME e-mail address you had used. If the forum system says a user account has already been registered using that e-mail address then you're good... just wait for us to manually process your registration
  • If your user ID is not an obvious real name (i.e. firstname and lastname) then it may have gotten deleted.


You are able to actually log in, but you can't post new posts

If you are finding that you have to either log in each time you try to post something new, or even after clicking "Submit New Thread" you're finding the post never made it, then it may be that your computer's settings might be in conflict.
  • SFI uses the widely used forum software known as vBulletin which requires cookies to keep state of your login. If your browser security is set too high, it will disallow the cookies that SFI needs to work. The standard "Medium" setting works well on SFI. If you need to add SFI to an "Exceptions List" and your browser supports that, add "swordforum.com" to that list.
  • On rare occasion, one's firewall settings might be filtering out SFI for some odd reason. If you are using something other than Microsoft Firewall (i.e. third party software) you may need to add "swordforum.com" as a domain to your Exceptions List.